How to enable the paths of the AIX

2
15400

Different ways to Enable the path of the channel.

# lspath -l hdisk4
Failed  hdisk4 fscsi0
Failed  hdisk4 fscsi0
Enabled hdisk4 fscsi1
Enabled hdisk4 fscsi1

# rmpath -l hdisk4 -p fscsi0
paths Defined

#  lspath -l hdisk4
Defined hdisk4 fscsi0
Defined hdisk4 fscsi0
Enabled hdisk4 fscsi1
Enabled hdisk4 fscsi1

#  rmpath -d -l hdisk4 -p fscsi0
paths Deleted

# cfgmgr

# lspath -l hdisk4
Enabled hdisk4 fscsi0
Enabled hdisk4 fscsi0
Enabled hdisk4 fscsi1
Enabled hdisk4 fscsi1

Or you can use the chpath to enable the path as shown below

#chpath -l hdiskxx -p fscsixx -s enable

or you can use this script

lspv |grep -v rootvg |awk ‘{print $1}’ |while read a
do
chpath -l $a -p fscsix -s enable
chpath -l $a -p fscsix -s enable
done

2 COMMENTS

  1. Hi,

    If there’s a temporary failure (fibre-channel cable, or phyiscal HBA), once the problem is solved, shouldn’t the paths get automatically enabled again? Or ,based on your experience, once they fail does the admin must manually enable them?

    This post is right on for me since I come from Linux (I’m learning how AIX deals with multipathing).

    Thanks,
    Jorge

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.